Powered by Blogger.

VRRP GNS3



_________________________________________________
R1#show running-config 
Building configuration...

Current configuration : 770 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef

!
no ip domain lookup
ip domain name lab.local

!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.1.10
!
no ip http server
no ip http secure-server
!
control-plane

!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
_________________________________________________________
R2#show running-config 
Building configuration...

Current configuration : 770 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef

!
no ip domain lookup
ip domain name lab.local
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!         
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.1.10
!
no ip http server
no ip http secure-server
!
control-plane
!         
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

______________________________________________________
R3#show running-config 
Building configuration...

Current configuration : 968 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef

!
no ip domain lookup
ip domain name lab.local

!
interface FastEthernet0/0
 mac-address 0033.3333.3333
 ip address 192.168.1.3 255.255.255.0
 duplex auto
 speed auto
 vrrp 1 ip 192.168.1.10
 vrrp 1 timers advertise 3
 vrrp 1 timers learn
 vrrp 1 priority 120
 vrrp 1 authentication cisco
!
interface FastEthernet0/1
 ip address 192.168.3.3 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 4
 network 192.168.1.0
 network 192.168.3.0
 auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!         
control-plane

line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
______________________________________________________
R4#show running-config 
Building configuration...

Current configuration : 947 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
no ip domain lookup
ip domain name lab.local
!
interface FastEthernet0/0
 mac-address 0044.4444.4444
 ip address 192.168.1.4 255.255.255.0
 duplex auto
 speed auto
 vrrp 1 ip 192.168.1.10
 vrrp 1 timers advertise 3
 vrrp 1 timers learn
 vrrp 1 authentication cisco
!
interface FastEthernet0/1
 ip address 192.168.2.4 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 4
 network 192.168.1.0
 network 192.168.2.0
 auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end     
_______________________________________________
R5#show running-config 
Building configuration...

Current configuration : 893 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R5
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
ip cef
!
!
!
!
no ip domain lookup
ip domain name lab.local     
interface Loopback5
 ip address 10.0.0.4 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.3.5 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 192.168.2.5 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 4
 network 10.0.0.0
 network 192.168.2.0
 network 192.168.3.0
 auto-summary
!
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!         
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end

Cisco SDM Configuration on CISCO router


I hope you will be in the best of your health. Just enable CISCO SDM access on my office router. Thought to share the configurations with you people too :


ip http server
ip http secure-server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
username XXXXXXX privilege 15 secret 0 YYYYYYYY

Router(config)# line vty 5 15
Router(config-line)# privilege level 15
Router(config-line)# login local
Router(config-line)# transport input telnet ssh
Router(config-line)# exit
Router(config)#
Router(config)# logging buffered 51200 warning
Router(config)# end
Router#

I hope this post was helpful for you guys too. Keep me posted with your comments and feedback, as i would love to hear from you!



How to set Secure CRT as default terminal in GNS3


Step # 1 Download Secure CRT from : http://thepiratebay.se/torrent/7438817/VanDyke.SecureCRT.v7.0.0.326-ZWT(x86)
Install the software according to its default directory setting.

Step # 2 Open your GNS3 Edit --- > Preference Box menu , from here go to General --- > Terminal Settings


Step # 3 Select the Secure CRT according to your OS from Preconfigurated terminal commands drop down box


In my case , as i am using 64-bit OS, i have selected SecureCRT(Windows 64-bit), once selected, click the Use button and you are good to use CRT! Great..

As a demonstration, i have opened my all routers in a single sweet looking window of Secure CRT :


I hope this post was helpful for you. Please let me know your feedback, your questions are welcomed in the comments box below.

ARP / Router CPU History / TTL and DNS

So far during my studies, i came across ARP, Router CPU history, TTL value of a packet and DNS working.

To check ARP table on a CISCO router:

#show ip arp

It will display all the resolved addresses that are present on a router. Cisco router will keep ARP entry for around 4 hours. Off-course you do know ARP stands for Address Resolution Protocol. 

DNS: Domain name System can either use UDP or TCP port 53. If a host is trying to resolve some domain name, it will send request using UDP to port 53 but if DNS doesn't respond, then the host will try sending request using DNS TCP port 53. UDP -- > TCP (53)

TTL (Time to Live) : Yes this field is used in data packet to make its life easy :) Each router through which the packet passes, will decrement the TTL value in data packet ( TTL value starts from 255) by one. Once it reaches zero, the packet will be discarded and hence it (Packet) will not circulate for ever. Just imagine if there was no TTL field in the packets which are roaming wildly the global internet !

MTU: Maximum transmission unite is 1500 bytes. its the maximum packet a router can transmit.

#show processes & #show processes cpu history


R1#show processes
CPU utilization for five seconds: 2%/0%; one minute: 0%; five minutes: 0%
 PID QTy       PC Runtime (ms)    Invoked   uSecs    Stacks TTY Process
   1 Cwe 6001F598            0          2       0 5664/6000   0 Chunk Manager
   2 Csp 609F9CDC            0       2520       0 2524/3000   0 Load Meter
   3 Lwe 611F71B8            8        436      18 5500/6000   0 CEF Scanner
   4 Mwe 61D95244            0          1       023372/24000  0 EDDRI_MAIN
   5 Lst 6001C4B0         6760       1384    4884 5416/6000   0 Check heaps
   6 Cwe 60023228            0          1       0 5656/6000   0 Pool Manager
   7 Mst 60F8C9B4            0          2       0 5496/6000   0 Timers
   8 Mwe 600B448C            0        211       0 5700/6000   0 IPC Dynamic Cach
   9 Mwe 600A59F4            0          1       0 5692/6000   0 IPC Zone Manager
  10 Mwe 600A4C5C           36      12593       2 5608/6000   0 IPC Periodic Tim
  11 Mwe 600A4AAC           44      12593       3 5632/6000   0 IPC Deferred Por
  12 Mwe 600A56CC            0          1       0 5564/6000   0 IPC Seat Manager
  13 Mwe 600AACD0            4          1    4000 5660/6000   0 IPC BackPressure
  14 Mwe 60253CA4            0          1       011664/12000  0 OIR Handler
  15 Mwe 60458374            0          1       023600/24000  0 Crash writer
  16 Msi 6055E184            0        421       0 5492/6000   0 Environmental mo
  17 Mwe 60B669BC            4        213      18 5648/6000   0 ARP Input
  18 Mwe 60BC0B50            0          2       0 5448/6000   0 ATM Idle Timer
  19 Mwe 60F48894            0          2       0 5484/6000   0 AAA high-capacit
  20 Lwe 60F4C6C0            0          1       0 5688/6000   0 AAA_SERVER_DEADT
  21 Mwe 60FB2F60            0          1       011644/12000  0 Policy Manager
 --More--

its quite a detailed command, showing memory utilization for each running process and as you can expect there are a lot of processes running on a CISCO router to enable the magic on it. One more output for your consideration, i would personally recommend below mentioned command, which plot a nice graph of the cpu utilization:

R1#show processes cpu history

R1   03:32:13 AM Friday Mar 1 2002 UTC



    22211111
100
 90
 80
 70
 60
 50
 40
 30
 20
 10
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per second (last 60 seconds)



    112  11 1111 111 111  111 1    1     11 1  1   11     1 213
100
 90
 80
 70
 60
 50
 40
 30
 20
 10
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%



    342
100
 90
 80
 70
 60
 50
 40
 30
 20
 10
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
             0    5    0    5    0    5    0    5    0    5    0    5    0
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%

I hope you enjoyed reading above post. Please do comment and let me know your feedback, please also post your questions and confusions in below comments box. Thanks 

All things about CISCO IOS



We will cover all important points regarding CISCO IOS- Cisco Internetworking Operating System, that are commonly asked on a CCNA exam. So let`s start from the beginning: 

When you log into a CISCO router:

Router>
User EXEC mode
Router#
Privileged EXEC mode
Router(config)#
Configuration mode
Router(config-if)#
Interface level (within configuration mode)
Router(config-router)#
Routing engine level (within configuration mode)
Router(config-line)#
Line level (vty, tty, async) within configuration mode

Running configurations reside on RAM, we issue copy running-config startup-config command to move the configs from RAM to NVRAM or in simple words to save it. To load configs from a TFTP server we use copy TFTP: running-config command.

When you turn the router on, it runs through the following boot process. The Power-On Self Test (POST) checks the router’s hardware. When the POST completes successfully, the System OK LED indicator comes on.

The router checks the configuration register to identify where to load the IOS image from. A setting of 0×2102 means that the router will use information in the startup-config file to locate the IOS image. If the startup-config file is missing or does not specify a location, it will check the following locations for the IOS image:

1. Flash (the default location)
2. TFTP server
3. ROM (used if no other source is found)

The router loads the configuration file into RAM (which configures the router). The router can load a configuration file from:

+ NVRAM (startup-configuration file)
+ TFTP server

If a configuration file is not found, the router starts in setup mode.
Okay, in this micro post one more thing, we need to see is what can “show version” command tells us about CISCO IOS:

Software Version
- IOS software version (stored in flash)
Bootstrap Version
- Bootstrap version (stored in Boot ROM)
System up-time
- Time since last reboot
System restart info
- Method of restart (e.g. power cycle, crash)
Software image name
- IOS filename stored in flash
Router Type and Processor type
- Model number and processor type
Memory type and allocation (Shared/Main)
- Main Processor RAM
- Shared Packet I/O buffering
Software Features
- Supported protocols / feature sets
Hardware Interfaces
- Interfaces available on router
Configuration Register
- Bootup specifications, console speed setting, etc.

The following is a sample output of a show version command.

Router# show version
Cisco Internetwork Operating System Software
IOS (tm) 3600 Software (C3640-J-M), Version 11.2(6)P, SHARED PLATFORM,
RELEASE SOFTWARE (fc1)
Copyright (c) 1986-1997 by cisco Systems, Inc.
Compiled Mon 12-May-97 15:07 by tej
Image text-base: 0x600088A0, data-base: 0x6075C000

ROM: System Bootstrap, Version 11.1(7)AX [kuong (7)AX], EARLY DEPLOYMENT
RELEASE SOFTWARE (fc2)

Router uptime is 1 week, 1 day, 38 minutes
System restarted by power-on
System image file is "flash:c3640-j-mz_112-6_P.bin", booted
via flash
Host configuration file is "3600_4-confg", booted via tftp
from 171.69.83.194

cisco 3640 (R4700) processor (revision 0x00) with 107520K/23552K bytes
of memory.
Processor board ID 03084730
R4700 processor, Implementation 33, Revision 1.0
Bridging software.
SuperLAT software copyright 1990 by Meridian Technology Corp).
X.25 software, Version 2.0, NET2, BFE and GOSIP compliant.
TN3270 Emulation software.
Primary Rate ISDN software, Version 1.0.
2 Ethernet/IEEE 802.3 interface(s)
97 Serial network interface(s)
4 Channelized T1/PRI port(s)
DRAM configuration is 64 bits wide with parity disabled.
125K bytes of non-volatile configuration memory.
16384K bytes of processor board System flash (Read/Write)

Configuration register is 0x2102

Commands execution hierarchy on IOS is like :


some other interesting commands worth knowing on a CISCO IOS are :


R1#show file systems
File Systems:

     Size(b)     Free(b)      Type  Flags  Prefixes
           -           -    opaque     rw   archive:
           -           -    opaque     rw   system:
       57336       57051     nvram     rw   nvram:
           -           -    opaque     rw   null:
           -           -   network     rw   tftp:
*   16777212    16777212     flash     rw   flash:
           -           -     flash     rw   slot0:
           -           -    opaque     wo   syslog:
           -           -    opaque     rw   xmodem:
           -           -    opaque     rw   ymodem:
           -           -   network     rw   rcp:
           -           -   network     rw   pram:
           -           -   network     rw   ftp:
           -           -   network     rw   http:
           -           -   network     rw   scp:
           -           -   network     rw   https:
           -           -    opaque     ro   cns:



R1#show inventory
NAME: "2691 chassis", DESCR: "2691 chassis"
PID:                   , VID: 0.1, SN: XXXXXXXXXXX


R1#show diag
2691 Backplane EEPROM:
        PCB Serial Number        : XXXXXXXXXXX
        Processor type           : 66
        Top Assy. Part Number    : 800-09616-02
        Board Revision           : F0
        Fab Part Number          : 28-4226-06
        Deviation Number         : 65535-65535
        Manufacturing Test Data  : FF FF FF FF FF FF FF FF
        RMA Number               : 255-255-255-255
        RMA Test History         : FF
        RMA History              : FF
        Chassis Serial Number    : XXXXXXXXXXX
        Chassis MAC Address      : c000.1310.0000
        MAC Address block size   : 32
        Field Diagnostics Data   : FF FF FF FF FF FF FF FF
        Hardware Revision        : 0.1
        Number of Slots          : 1
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 58 58 58 58 58 58 58 58 58 58 58 09
          0x10: 66 40 02 58 C0 46 03 20 00 25 90 02 42 46 30 85
          0x20: 1C 10 82 06 80 FF FF FF FF C4 08 FF FF FF FF FF
          0x30: FF FF FF 81 FF FF FF FF 03 FF 04 FF C2 8B 58 58
          0x40: 58 58 58 58 58 58 58 58 58 C3 06 C0 00 13 10 00
          0x50: 00 43 00 20 C5 08 FF FF FF FF FF FF FF FF 41 00
          0x60: 01 01 01 FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF
Slot 0:
        C2691 Mother board 2FE(TX)-3W Port adapter, 2 ports
        Port adapter is analyzed
        Port adapter insertion time unknown
        EEPROM contents at hardware discovery:
        PCB Serial Number        : XXXXXXXXXXX
        Processor type           : 66
        Top Assy. Part Number    : 800-09616-02
        Board Revision           : F0
        Fab Part Number          : 28-4226-06
        Deviation Number         : 65535-65535
        Manufacturing Test Data  : FF FF FF FF FF FF FF FF
        RMA Number               : 255-255-255-255
        RMA Test History         : FF
        RMA History              : FF
        Chassis Serial Number    : XXXXXXXXXXX
        Chassis MAC Address      : c000.1310.0000
        MAC Address block size   : 32
        Field Diagnostics Data   : FF FF FF FF FF FF FF FF
        Hardware Revision        : 0.1
        Number of Slots          : 1
        Product (FRU) Number     : C2691-2FE
        EEPROM format version 4
        EEPROM contents (hex):
          0x00: 04 FF C1 8B 58 58 58 58 58 58 58 58 58 58 58 09
          0x10: 66 40 02 58 C0 46 03 20 00 25 90 02 42 46 30 85
          0x20: 1C 10 82 06 80 FF FF FF FF C4 08 FF FF FF FF FF
          0x30: FF FF FF 81 FF FF FF FF 03 FF 04 FF C2 8B 58 58
          0x40: 58 58 58 58 58 58 58 58 58 C3 06 C0 00 13 10 00
          0x50: 00 43 00 20 C5 08 FF FF FF FF FF FF FF FF 41 00
          0x60: 01 01 01 FF FF FF FF FF FF FF FF FF FF FF FF FF
          0x70: FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF FF

 One other things, mostly a CCNA student like me is confuse. Its the value of config register. The simple philosophy behind it is if config register value is 0x2102, router will look for configuration in NVRAM:

R1#show version | include register
Configuration register is 0x2102

If we change the config register valure form global configuration to 0x2142, any configuration in NVRAM will be ignored if a router is rebooted and it will enter into initial configuration mode. Please reread the last sentence multiple times to solidify the concept. 

(Please note, i will keep on updating this post to add more fresh information into it, so you dont need to studty different dumps again and again :) Please leave your comments and suggestion, it would really help me to learn more and more)

Memory and Flash on CISCO router




Before you install a new Cisco IOS Software image on your router, check if your router meets the memory requirements for that image. For this, issue theshow version command on your router, and look for these lines:
...
cisco RSP4 (R5000) processor with 65536K/2072K bytes of memory
...
16384K bytes of processor board System flash (Read ONLY)
The first line tells you how much Dynamic RAM (DRAM) and Packet memory are installed in your router. Some platforms use a fraction of their DRAM as Packet memory. The memory requirements take this into account, so you have to add both numbers to find the amount of DRAM available on your router (from a memory requirement point of view).

Example 1: Separate DRAM and Packet Memory

... 
cisco RSP4 (R5000) processor with 65536K/2072K bytes of memory
...
The 4000, 4500, 4700, and 7500 routers have separate DRAM and Packet memory, so you only need to look at the first number. This shows that the router has 65536 K (or 64 M) of DRAM.

Example 2: Combined DRAM and Packet Memory

... 
cisco 2611 (MPC860) processor (revision 0x202) with 29696K/3072K bytes of memory 
...
The 1000, 1600, 2500, 2600, 3600, and 7200 routers use a fraction of DRAM as Packet memory, so you need to add both numbers to find out the real amount of DRAM. In this example, the router has 2969 K + 3072 K = 32768 K (or 32 M) of DRAM.

Example 3: Available Flash Memory

...
cisco RSP4 (R5000) processor with 65536K/2072K bytes of memory
...
16384K bytes of processor board System flash (Read ONLY)
The bottom line tells you how much Flash memory is available. Some of it might already be in use. In order to find out the amount of free Flash memory, issue a show flash command:
Router#show flash 

System flash directory: 
File   Length   Name/status 
  1    8407884  c2600-io3s56i-mz.121-6 
[8407948 bytes used, 8369268 available, 16777216 total] 
16384K bytes of processor board System flash (Read/Write)
Variants of the show flash command can be used to inspect different specific Flash devices on the platform. Refer to the show flash command definitionfor information on how to use these variants.
You need to satisfy both the DRAM and the Flash requirements to be able to use the software you choose. If you do not meet the requirements, you can either add more Flash or more DRAM in the router, or choose another Cisco IOS Software release. You may also consider a reduced feature set or an older release, since they have less features, and therefore fewer requirements.

(Courtesy : http://www.cisco.com/en/US/products/sw/iosswrel/ps1834/products_tech_note09186a00800fb9d9.shtml)

GLBP Gateway Load Balancing Protocol


I was working on an assignment involving GLBP implementation for Network Redundancy. I was totally un aware of this Protocol. Although i had some exposure to HSRP but was not aware of GLBP! This was totally an alien concept for me. Thankful to Mr Keith Barker! Who has made an outstanding video on Youtube, covering all the basics of GLBP and giving a detailed overview of its configurations. In this video Keith has covered almost all of the major components related to GLBP. A must watch video for a Network Engineer.







Quick Facts:

  • GLBP uses 224.0.0.102 UDP/3222
  • GLBP default Hello interval is 3 seconds
  • GLBP has virtual MAC 0007.b4xx.xxyy with xx being group number and yy being forwarder number
  • GLBP allows up to 4 virtual MAC address per group
  • Elected Active Virtual Gateway (AVG) assigns/revokes virtual MAC to/from group members
  • Each gateway is an Active Virtual Forwarder (AVF) and answers own ARP request